注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

亮丽

一直想安静的过着安静的日子,安静的爱着爱我的人

 
 
 

日志

 
 
 
 

配置pgi f90编译器:  

2009-01-04 22:07:38|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

77不支持动态分配数组,你需要用F90的编译器,需要配置好mpif90,搜搜资料,下面是针对pgi的配置

# 配置pgi f90编译器:

这个直接安装就成(注意选择服务器版),装完以后配置环境,这里为了所有用户都可以用,所以修改/etc/profile文件:

-----------------------------------------------------------------------

PGI=/usr/pgi

export PGI

PATH=$PGI/linux86/5.1/bin:$PATH

export PATH

export LD_LIBRARY_PATH=/usr/pgi/linux86/5.1/lib

MANPATH=$MANPATH:$PGI/man

export MANPATH

export LIBS="-L/usr/local/pgi/linux86/5.1/lib -lpgftnrtl -lpgc"

-----------------------------------------------------------------------

注:感觉intel的性能更好一点,配置类似,在此不多说。

# 配置mpich:

从这里下载http://www-unix.mcs.anl.gov/mpi/mpich/download.html

安装:

进入解压后的目录,按照需要执行类似下面的命令:

% ./configure --enable-debug -fc=pgf77 -f90=pgf90 --prefix=/usr/local/mpich

类似pgi的配置,修改/etc/profile文件:

-----------------------------------------------------------------------

export MPICH=/usr/local/mpich

export PATH=$MPICH/bin:$PATH

 

今天很happy,在37号节点上成功的安装了mpich2版本,并且通过设置以上环境变量,使得mpif90在任何目录下都可以直接使用 ,^_^,         ( ) ( )
         | |_| |   _ _  _ _    _ _    _   _
         |  _  | /'_` )( '_`\ ( '_`\ ( ) ( )
         | | | |( (_| || (_) )| (_) )| (_) |
         (_) (_)`\__,_)| ,__/'| ,__/'`\__, |
                       | |    | |    ( )_| |
                       (_)    (_)    `\___/'

-----------------------------------------------------------------------

注:其实这里的mpich debian自带,可以按照安装一般包类似进行安装。

  评论这张
 
阅读(588)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017